firelike / share-a-sale-api-client

Zend Framework module to consume Share-A-Sale API


Share-A-Sale API Client

Build Status License

Introduction

Zend Framework module to consume Share-A-Sale API

Installation

Install the module using Composer into your application's vendor directory. Add the following line to your composer.json.

{
    "require": {
        "firelike/share-a-sale-api-client": "1.*"
    }
}

Configuration

Enable the module in your application.config.php file.

return array(
    'modules' => array(
        'Firelike\ShareASale'
    )
);

Copy and paste the shareasale.local.php.dist file to your config/autoload folder and customize it with your credentials and other configuration settings. Make sure to remove .dist from your file.Your shareasale.local.php might look something like the following:

<?php
return [
    'shareasale_service' => [
        'service_url' => 'https://shareasale.com',
        'service_version' => '2.1',
        'affiliate_id' => '<affiliate-id>',
        'token' => '<token>',
        'secret_key' => '<secret-key>',
    ]
];

Usage

Calling from your code:

        use Firelike\ShareASale\Service\ShareASaleService;
        
        $service = new ShareASaleService();
        
        $options = [
            'dateStart' => '6/22/2016',
        ];
        
        $records = $service->activity($options);
        
        var_dump($records);
        

Using the console:

php public/index.php shareasale activity -v

Implemented Service Methods:

  • activity
  • activitySummary
  • merchantTimespan
  • dailyActivity
  • monthlySummary
  • voidtrail
  • traffic
  • apitokencount
  • getProducts
  • invalidLinks
  • orderInquiry
  • merchantDataFeeds
  • couponDeals
  • merchantStatus
  • merchantCreative
  • merchantGiftCard
  • edittrail
  • paymentSummary
  • merchantSearch
  • merchantSearchProduct
  • ledger
  • balance

Links

No license file found for this Module
php composer.phar require "firelike/share-a-sale-api-client"

Require

  • php: ^5.6 || ^7.0
  • guzzlehttp/guzzle: ^6.2
  • zendframework/zend-servicemanager: ^3.1
  • zendframework/zend-validator: ^2.8
  • zendframework/zend-mvc-console: ^1.1

Require Dev

  • phpunit/phpunit: ^5.7